Views Reply Votes
Samantha Cesar
Samantha
 8
CIM load of Product Descriptions with special characters in the description
127
8
00
Posted: Aug 20, 2019   
Votes
Shivakumar Patil
Shivakumar
 45
Replied 

Hi Samantha,

you will need to use double double quotes.

for example if we need to store value somthing like this 0.15" - 0.04" so i need to input like this

"0.15"" - 0.04""", note there are two double quotes after 0.15''" and three double quotes after 0.04"""

 

another way ypu can do is use quoter(field) in the program while creating CIM 

00
Replied: Aug 20, 2019
Votes
Samantha Cesar
Samantha
 8
Replied 

Thank you.  Based on your answer, I was able to resolve the issue when the description contains quotes (").  However, I still can't resolve the issue when the description contains a backslash.  For example, I'm trying to load the below description into the description 1 field in 1.4.3

N158x31x279/T/CsI(Na)

I have tried

“”N158x31x279/T/CsI(Na)””

“N158x31x279””/T/””CsI(Na)”

“N158x31x279””/””T””/””CsI(Na)”

“N158x31x279/T/””CsI(Na)”

None of these work.  Therefore, how do I format N158x31x279/T/CsI(Na) so that it loads correctly into description line 1 in 1.4.3?

00
Replied: Aug 21, 2019
Votes
Phill Norrey
Phill
 1334
Replied 
the / is not the problem it is the " that causes the problem.  I use a macro in excel to create CIM's so cannot do the doubl double thing.  however I replace the " in the description with 2 single ' so it looks the same.  I just created a CIM load using your two descriptions but replacing " with ''(2 single ') and both loaded perfectly
00
Replied: Aug 21, 2019
Votes
Samantha Cesar
Samantha
 8
Replied 

I replaced the  " with ''(2 single ') and it works perfectly for the .040"x7" Thor Tung 2% but not for the N158x31x279/T/Csi(NA).  N158x31x279/ Is put in the description line 1 field and /CSi(NA) is put on the second line.  Below is what I loaded.  What am I doing wrong?

 

@@batchload ppptmt04.p
''NAI(TL)32 INGOT''
''Ea'' ''N158x31x279/T/CsI(Na)'' ''Ribbon''
-
.
.
@@end

 

 

00
Replied: Aug 21, 2019
Votes
Samantha Cesar
Samantha
 8
Replied 

Furhter clarification, this is how the detail from the CIM Load is populating the description field.  For some reason it's dividing the description between two lines and also puting quotes in the description (not sure why)

Description Line 1:   N158x31x279/

Description Line 2:   T"/CsI(Na)"

 

00
Replied: Aug 21, 2019
Votes
Irfan Jamal
Irfan
 7
Replied 

Hi Samantha,

I have tested the following input using a simple program I wrote to accept a single field and it worked fine: "N158x31x279/T/CsI(Na)" loaded as N158x31x279/T/CsI(Na) in a single field.

From the input you posted, you seem to be using two single quotes in place of ALL double quotes. Phil's suggestion was to use two single quotes ONLY where you want the quote to appear in the input field. (0.040" would be 0.040'' - 2 single instead of a double)

However, that method can occasionally run into issues where your text becomes too long for the QAD Input field. Shivakumar's method of using a 2 double quotes, if you have the option, would be the way to go.

So for your 2 descriptions, please try (all double quotes):
"N158x31x279/T/CsI(Na)"
".040""x7"" Thor Tung 2%"

Also, change all single quotes everywhere else to double quotes. Let me know if you run into any issues.

 

00
Replied: Aug 21, 2019
Votes
Irfan Jamal
Irfan
 7
Replied 

Testing the following using ppptmt04.p just to make sure it worked (note, all double quotes):
"NAI(TL)32 INGOT"
"Ea" "N158x31x279/T/CsI(Na)" "Ribbon"
-
.
.
@@end

Result (copied from output):
      Item Number: NAI(TL)32 INGOT      Description: N158x31x279/T/CsI(Na)
  Unit of Measure: Ea                                Ribbon

 

Let me know if you have any issues

00
Replied: Aug 21, 2019
Votes
Samantha Cesar
Samantha
 8
Replied 
Thank you to everyone.  Using what you had all replied to me, I was able to get both descriptions to load correctly.  I was confused about the use of quotes
10
Replied: Aug 21, 2019
Forums
All
Forum Help
Help Using Forums