Views Reply Votes
Glen Diener
Glen
 6
Empty QXI Response for QGen Created Custom QXI UI Adapter
207
2
00
Posted: Oct 10, 2018   
Votes
Wisnu Putra
Wisnu
 6
Replied 

Hi Glen,

If you are creating the schema using QGen, then you need to make sure the primary key is set to "yes" if you want to include it in the response when you mapped the screen.
You can see this information in Qxtend User Guide, here is the captured information  :

  https://drive.google.com/file/d/19crWo1nJ4UE_HVO1KjLS0zBHvkUlefY9/view

Hope that helps.

Wisnu.

10
Replied: Oct 10, 2018
Votes
Glen Diener
Glen
 6
Replied 

Wisnu, thank you for this reminder. However, when mapping the screen I did set the fields I wanted included in the response as Primary Keys. Below are a couple of screen shots from the QGen mapping process. I've also included the first couple lines of the generated .dat file. I believe the 11th column in this CSV file identifies primary keys.

 

Snippet of the .dat file generated by QGen.

1000,"distributionOrder",1,"Start/End Iteration","f4","a","dss_nbr","dssNbr#0:a021","dssNbr","Order Number",yes,no,0,"x(8)","CHARACTER","dss_mstr","RETURN",yes,no,no,no,"","","",yes,yes,"dsCmmts#0:d0101",no
2000,"",1,"None","","a","dss_shipsite","dssShipsite#0:a021","dssShipsite","Ship-From",yes,no,0,"x(8)","CHARACTER","dss_mstr","RETURN",yes,no,no,no,"","","",yes,yes,"",no
3000,"",1,"None","","a","dss_rec_site","dssRecSite#0:a021","dssRecSite","Ship-To",no,no,0,"x(8)","CHARACTER","dss_mstr","RETURN",yes,no,no,no,"","","",yes,yes,"",no
4000,"",1,"None","","b","dss_created","dssCreated#0:b0121","dssCreated","Date Created",no,no,0,"99/99/99","DATE","dss_mstr","RETURN",yes,no,no,no,"","","",yes,yes,"",no

- Glen

 

 

00
Replied: Oct 11, 2018
Forums
All
Forum Help
Help Using Forums